bugGNUstep - Bugs: bug #21262, Creeping menus

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #21262: Creeping menus

Submitted by:  Mark Tracy <tracy454>
Submitted on:  Fri 05 Oct 2007 07:44:56 AM UTC  
 
Category:  Gui/AppKit Severity:  3 - Normal
Item Group:  None Status:  Invalid
Privacy:  Public Assigned to:  None
Open/Closed:  Closed

Sun 07 Oct 2007 10:55:30 AM UTC, comment #4:

Closed as it was reported to be a virtualisation issue.

Fred Kiefer <FredKiefer>
Project Member
Sat 06 Oct 2007 06:00:42 PM UTC, comment #3:

On further testing, it appears that GNUstep is not the source of this bug. I now believe that it is related to my virtual environment. Under Gnome, all windows creep. Under WindowMaker, only GNUstep menus creep. Parallels introduced some new convenience features that allow the mouse pointer to pass in and out of the Linux virtual environment without any hot-keys; I have notice some other mouse-related misbehavior that is unrelated to GNUstep.

Mark Tracy <tracy454>
Sat 06 Oct 2007 06:26:08 AM UTC, comment #2:

I am using the default NSNextStepInterfaceSytle vertical menus. I tried setting GSX11HandlesWindowDecor to YES and NO but the behavior was the same. Standalone GNUstep applications. Application windows are well-behaved. WindowMaker menus are well-behaved.

Mark Tracy <tracy454>
Fri 05 Oct 2007 11:01:34 AM UTC, comment #1:

Could you please provide some more information. I am not able to reproduce this behaviour.

Which sort of menus are you using? Horizontal, wild menu or the standard ones?
What is your setting for the handling of window decoration?
Standalone GNUstep applications or a GNUstep desktop?

Fred Kiefer <FredKiefer>
Project Member
Fri 05 Oct 2007 07:44:56 AM UTC, original submission:

With gui-0.13 (trunk) a menu will creep across the screen when I click in its title bar. On mouse-down the menu moves down and right 1 pixel. Sub-menus do the same. It happens with art and cairo backends, also with WindowMaker and Gnome window managers. So far all apps do it.

Mark Tracy <tracy454>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by FredKiefer (Posted a comment)
  • -email is unavailable- added by tracy454 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2007-10-07 FredKiefer StatusNone => Invalid
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.4