bugfindutils - Bugs: bug #18835, find -name option fails to...

 
 

bug #18835: find -name option fails to correctly handle certain Unicode filenames

Submitted by:  fbg00 <fbg00>
Submitted on:  Fri 19 Jan 2007 09:15:33 PM UTC  
 
Category:  find Severity:  3 - Normal
Item Group:  Wrong result Status:  Invalid
Privacy:  Public Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.2.27 Fixed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 24 Feb 2007 07:05:41 PM UTC, comment #3: 

No response from submitter.  I think this is just an environment problem.  Hence closing as invalid.   If you do have some other comments to make, you can just add them to this bug again (I can reopen it).

James Youngman <jay>
Project Administrator
Sat 20 Jan 2007 03:40:31 PM UTC, comment #2: 

It looks to me like your character set settings in your terminal emulator do not match the ones in your shell's environment.

James Youngman <jay>
Project Administrator
Sat 20 Jan 2007 08:58:52 AM UTC, comment #1: 

Works for me with 4.2.28.

It will still fail if different encodings are used, i.e. if a file with a iso8859-1 encoded filenamed is searched with find under an unicode locale. See bug #16520

cu andreas

Andreas Metzler <ametzler>
Fri 19 Jan 2007 09:15:33 PM UTC, original submission:  

find -name option fails to correctly handle certain Unicode filenames.  For example:

$ find -name "*.txt" -print

will fail to recognize Lucía.txt

Sample command set reproducing problem
Linux version 2.6.15-23-server (buildd@rothera) (gcc version 4 .0.3 (Ubuntu 4.0.3-1ubuntu5)) #1 SMP Tue May 23 15:10:35 UTC 2006
find version 4.2.27

$mkdir t1131
$cd t1131
$ touch Lucía.txt
$ touch lucia.txt
$ find . -name "*.txt" -print
./lucia.txt
$ find . -print | grep -i "\.txt$"
./Lucía.txt
./lucia.txt

Sorry, did not check in later versions of findutils.

fbg00 <fbg00>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jay (Posted a comment)
  • -email is unavailable- added by fbg00 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2007-02-24 jay StatusNone => Invalid
        Open/ClosedOpen => Closed
    2007-01-20 ametzler Carbon-CopyRemoved 20807 => -

    Back to the top


    Powered by Savane 3.5