bugfindutils - Bugs: bug #17861, make of find fails on Solaris 2.8

 
 

bug #17861: make of find fails on Solaris 2.8

Submitted by:  Kashif Ahmad <ahmadk72>
Submitted on:  Wed 27 Sep 2006 04:30:32 PM UTC  
 
Category:  find Severity:  3 - Normal
Item Group:  Compilation Failure Status:  Need Info
Privacy:  Public Assigned to:  James Youngman <jay>
Originator Name:  Kashif Ahmad Open/Closed:  Closed
Release:  4.2.28 Fixed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 15 Apr 2007 07:48:50 PM UTC, comment #5: 

No response.  Closing the bug.

James Youngman <jay>
Project AdministratorIn charge of this item.
Sat 03 Mar 2007 02:07:19 AM UTC, comment #4: 

Please respond to my earlier question...

James Youngman <jay>
Project AdministratorIn charge of this item.
Thu 11 Jan 2007 12:52:55 AM UTC, comment #3: 

This should now be fixed in the CVS code for findutils 4.2.x.  Could you tell me whether findutils version 4.3.2 is also affected by this problem?

James Youngman <jay>
Project AdministratorIn charge of this item.
Tue 28 Nov 2006 07:41:22 PM UTC, comment #2: 

same error for solaris 2.8 build of find utils 4.2.29

same error shows up on HPUX build of find utils 4.2.29

I did not see, in the help, an option to force
including the provided regex code in gnulib.

Anonymous
Sun 22 Oct 2006 09:30:53 PM UTC, comment #1: 

exactly same thing on Solaris 10, build of findutils
4.2.28 fails for same reason.

Anonymous
Wed 27 Sep 2006 04:30:32 PM UTC, original submission:  

Error:

gcc  -g -O2   -o find  find.o fstype.o parser.o pred.o tree.o util.o version.o ../lib/libfind.a ../gnulib/lib/libgnulib.a
Undefined                       first referenced
 symbol                             in file
re_compile_pattern                  parser.o
re_match                            pred.o
re_set_syntax                       parser.o
ld: fatal: Symbol referencing errors. No output written to find
collect2: ld returned 1 exit status

Additional information:

4.2.27 installation works without a problem.  Seems like a problem in the treatment of the regex included with package (which it should default to once the Solaris one is found lacking).  Tried configuring with --with-included-regex and still same problem.  Looks very similar to bug #11710.

Kashif Ahmad <ahmadk72>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jay (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2007-04-15 jay Open/ClosedOpen => Closed
    2007-01-13 jay Carbon-Copy- => Added randy.causey@intecbilling.com
    2007-01-11 jay Assigned toNone => jay
    2007-01-11 jay StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5